The HHR AC system just got stupid

Standard

The AC compressor just clicks but won’t stay engaged

It appears that the AC system on the HHR has developed a glitch. When I went to use it the other day it didn’t seem to be doing it’s job so I suspected that it was just low on 134. So I got out the gauge and a can of 134 and plugged in to check it out. It was a bit low but not enough to stop working. A bit more investigation and I found that the compressor was just clicking in for a second at a time and not staying engaged. so now I will have to make the decision as to whether to fumble around with it or just grit my teeth and take it in somewhere.

Unfortunately I have to use it this weekend Saturday so it will have to wait until Monday to head somewhere if that is what I am going to do. So until then I will do some more TS and see if I can come up with a reason and a fix.


UPDATE and FIX – After a bit of research this sis what I found. It appears that some, the key word here is SOME, AC units don’t like more than 45 ponds in the system. When you exceed that it kicks the over pressure switch. Low and behold, when I released some of the pressure back to 45 pounds, it started acting normal. So lesson learned. It was the over pressure kicking in just at a bit lower than expected. Works like a charm!

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s